abdera-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James M Snell (JIRA)" <j...@apache.org>
Subject [jira] Commented: (ABDERA-116) JdbcCollectionAdapter class name and package are ambiguous
Date Tue, 12 Feb 2008 18:17:08 GMT

    [ https://issues.apache.org/jira/browse/ABDERA-116?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12568266#action_12568266
] 

James M Snell commented on ABDERA-116:
--------------------------------------

I have to agree with David on this one.  The adapter naming should reflect the specific mapping
layer being used.  In this case, calling it IbatisCollectionAdapter would be accurate, unambiguous
and tells the user generally how the adapter works.

> JdbcCollectionAdapter class name and package are ambiguous
> ----------------------------------------------------------
>
>                 Key: ABDERA-116
>                 URL: https://issues.apache.org/jira/browse/ABDERA-116
>             Project: Abdera
>          Issue Type: Improvement
>            Reporter: David Calavera
>             Fix For: 0.4.0
>
>         Attachments: ibatisAdapter.patch
>
>
> JdbcCollectionAdapter class name is ambiguous because it uses ibatis library to connect
the database instead of a native jdbc connector. This class should be renamed to IBatisCollectionAdapter
and moved to an appropiate package

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message