abdera-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From herbert <i...@gmx.de>
Subject Re: [jira] Created: (ABDERA-61) Invalid byte 2 of 3-byte UTF-8 sequence
Date Thu, 06 Sep 2007 11:27:02 GMT

Hi there!

1)

Chris Berry wrote:
> 
> 
>>[...] 
>>So what is happening is that the Reader (created by StAXUtils and
subsequently Woodstox)
>>uses the default encoding (MacRoman in my case)
>>Which is the reason why it works in Linux -- the default encoding is
UTF-8.
>>
>>I don't know what Herbert's default encoding is....
> 
> 

I'm using Windows XP Professional, so I assume, my default encoding is
Cp1252.
How can I find out exactly, which default encoding I'm using?

Is it the file-encoding I get, when printing out this line:
System.out.println("My encoding: "+System.getProperty("file.encoding")); ?
This gives me a Cp1252.

2)

James M Snell wrote:
> 
> 
>> [...]
>> Please give this patch a try.  This is a refactored version of what
>> Chris provided earlier.
>> [...]
> 
> 

I've checked out the branch 0.3.0-incubating 573049, applied your patch to
it
and made an ant-build-dist.

I've tried the freshly-built jars in my test-project and it also does *not*
work. Same thingi.

I'm very sure, that I've applied the patch right, but it was the first time,
I've done this,
so there is the eventuality, that I made something wrong.
A way to re-check my patching would be, if you provide me with the already
patched jars, though
- as just said - I'm quite sure, that I made it the correct way.

Does anyone has the facility to reproduce my issue against a
Lotus-Connections-1.0.1-Server?

3)

James M Snell wrote:
> 
> 
> [...]
> Hmmm...  notice that in your "ethereal stream 2", you're using chunked
> requests, release 0.2.2... 
> [...]
> 
> 

I do not use chunked requests explicitley. I assume, that's something 
abdera-client does for me, through the way I've set up my code.

Yes the "ethereal stream"'s were shot with release 0.2.2 but the
same error occurs with release 0.3.0.


James M Snell wrote:
> 
> 
> [...]
> .. and you did not capture the actual bits of the
> xml in the post.  
> [...]
> 
> 

I'm not sure, what you mean with "the actual bits of the
xml in the post.". I've captured the whole TCP-Stream, how ethereal
gave it to me.  IMO the xml of the post is included also. hmmm.



James M Snell wrote:
> 
> 
> [...]
> Would it be possible for you to capture another trace
> that includes the xml of the post?  Also, would it be possible for you
> to capture the hex output.  I want to see what bytes are actually being
> written to the wire.
> [...]
> 
> 

I will try it again.
I will capture the post again, this time with a 0.30-client and also in
hex-dump notation 
and post it to the JIRA.

Thanks anyway for all hints and help-attempts!

Herbert
-- 
View this message in context: http://www.nabble.com/-jira--Created%3A-%28ABDERA-61%29-Invalid-byte-2-of-3-byte-UTF-8-sequence-tf4383132.html#a12520551
Sent from the abdera-dev mailing list archive at Nabble.com.


Mime
View raw message